PHP Live! Help Desk
» Help Desk Home » Errors and Troubleshooting » Function Deprecated warnings on 1.x-3.x systems
Function Deprecated warnings on 1.x-3.x systems

PHP Live! v.3.x Important Notice

 

  • Security - It is recommended to discontinue use of the v.3.x series because the v.3.x codebase is outdated and may be vulnerable to today's exploit methods. If you have installed PHP Live! v.3.x series, we recommend deleting the outdated software right away!
  • Nulled - There have been reports of sites broadcasting numbers of "nulled" PHP Live! v.3.x series. DO NOT download the "nulled" PHP Live! v.3.x or any "nulled" software. "Nulled" software typically have been modified by a third-party and most likely contain malware or exploit methods built into the solution. If you have downloaded a "nulled" PHP Live! v.3.x or any "nulled" software, we recommend deleting the "nulled" software right away!

 

Support for version 3.x and prior has been discontinued and you are installing and using the v.3.x series "as is" with no warranty or guarantee from OSI Codes Inc.  The 3.x series (v.1.0-3.3 are all considered part of the 3.x series) are no longer a product of OSI Codes Inc. with no binding license or restrictions of use.  We strongly recommend a switch to the 4.x series to be inline with today's security standards and technology trends.

 


 

For those who receive function deprecated warning errors on v.1.x-3.x versions, you'll want to check the web server PHP version that is installed.  Your server admin should know the information.  Simply ask them "What version is the PHP running on our server?".

 

PHP >= 5.4.0 actually has the function session_register() removed.  Thus, the function doesn't even exist any longer with PHP >= 5.4.0.  There is nothing that can be done in this case to fix the error.  Technology does progress and unfortunately the core PHP removed a function that the PHP Live! 1.x-3.x systems relied on.  You'll want to consider switching to the new PHP Live! 4.x series or downgrade your core PHP to versions <= 5.3.  For more information on the session_register() function, visit the official PHP documentation.

 

For those with PHP <= 5.3, this error can be fixed by editing the php.ini file and update the error_reporting value.

 

  1. Contact the server admin to locate and access the php.ini on the server.
  2. Search for the string "error_reporting" and update the value so now it reads: error_reporting = E_ALL & ~E_DEPRECATED
  3. Save the php.ini file restart the web server.
  4. Done!

 

 

Was this documentation helpful to you?